You are NOT Logged in.
Chat about all aspects of snowsports, backcountry, climbing and mountaineering.
Goto Thread: PreviousNext
Goto: Forum ListMessage ListNew TopicSearchLog In
Goto Page:  Previous123Next
Current Page:2 of 3
geeo


Posts: 426
Joined: Sep 2006
Last Visited: 20:04
7th Feb 2019
Re: Winterhighland Android App Launched
Date Posted: 19.59hrs on Sun 22 Feb 15
A link to the relevant SAIS page on the resort overview would be great, also the MWIS forecast as you cant have too many sources, actually a nice low bandwidth grab of the info would be even better then I wouldn't need anything else smiling smiley

tim1mw


Posts: 700
Joined: Nov 2006
Re: Winterhighland Android App Launched
Date Posted: 22.27hrs on Sun 22 Feb 15
geeo Wrote:
A link to the relevant SAIS page on the resort overview would be great, also the MWIS forecast as you cant have too many sources, actually a nice low bandwidth grab of the info would be even better then I wouldn't need anything else


Hi Geeo, links are easy, so I'll add them in once I've sorted out the update which allows the links in the Twitter feed to work. I can also do a link to the "Low graphics" version of the MWIS forecast at the same time.

I'll give some thought to incorporating the MWIS forcast into the app properly, it seems to me that that would make the app useful for summer visitors as well. The web version of the report looks quite well structured and should compress very well. How much interest would there be in providing all the MWIS reports for all of Scotland vs just the ones that cover the Snow sports areas?



Edited 1 times. Last edit at 17.14hrs Mon 23 Feb 15 by tim1mw.

Bomp


Posts: 172
Joined: Nov 2010
Last Visited: 17:00
22nd Apr 2021
Re: Winterhighland Android App Launched
Date Posted: 06.33hrs on Mon 23 Feb 15
I like it a lot, one issue I'm having on slow connections is that the webcams appear to be trying to update very frequently - which means all the images go blank and then take ages to reload.

tim1mw


Posts: 700
Joined: Nov 2006
Re: Winterhighland Android App Launched
Date Posted: 10.48hrs on Mon 23 Feb 15
Hi Bomp,

The webcams should only be loading when you either tap on the webcams page or tap the refresh button, there isn't anything which triggers an automatic refresh while the page is open.

Could you try turning off the option on the "Use sequential webcam download" option on the "Config & Status" page. It might be the source of your problem.

Also, if you can let me know which version of Android and type of phone you are using I might be able to set up my emulator to match your configuration and replicate the problem.

FYI, the code this option turns off deliberately interferes with the "normal" process of loading images on the webcam page, the idea is to prevent the webcams all trying to load at once and saturating the bandwidth on a slow connection. I wrote this after waiting 5 minutes for a picture to show while using GPRS at the SYHA hostel in Braemar. The new code meant that the first image came up after ~20 seconds with the others following every 20 to 30 seconds or so, which is better than waiting 5 minutes anything at all.

Tim W

Jango


Posts: 9
Joined: Mar 2010
Last Visited: 22:39
19th Mar 2015
Re: Winterhighland Android App Launched
Date Posted: 11.42hrs on Mon 23 Feb 15
JUST downloaded app and very impressed. Nice and simple. Other features I would like to see are weather forecasts for the following week and not just the next day, and also a close app button. Well done though for a good app.

Bomp


Posts: 172
Joined: Nov 2010
Last Visited: 17:00
22nd Apr 2021
Re: Winterhighland Android App Launched
Date Posted: 11.58hrs on Mon 23 Feb 15
Thanks for replying Tim.
phone is Note 4 with 4.4.4 (easy to remember)

I've changed the setting as recommended.

It doesn't seem to have been a problem most of the time, but on at least two occasions it has done this: all the images go blank - as far as I can tell, without me doing anything to trigger it - and then reload (slowly).

EDIT: actually, after a quick play, one thing that does seem to trigger it is a screen rotate

tim1mw


Posts: 700
Joined: Nov 2006
Re: Winterhighland Android App Launched
Date Posted: 12.35hrs on Mon 23 Feb 15
Jango Wrote:
JUST downloaded app and very impressed. Nice and simple. Other features I would like to see are weather forecasts for the following week and not just the next day, and also a close app button. Well done though for a good app.


Hi Jango, if I can get the MWIS reports working in the app, then 3 day forecasts are an option. Right now I'm limited to what the resorts provide in there own feeds.

As for the close app button, the answer is Yes with qualification. The quick version is that app close buttons in Android either don't really close the app (and are window dressing to keep people who expect such a function happy) or do close the app but break recommended practice for Android development. There is a detailed reply on this topic to "mang_out" on the first page of this thread.

tim1mw


Posts: 700
Joined: Nov 2006
Re: Winterhighland Android App Launched
Date Posted: 13.24hrs on Mon 23 Feb 15
Hi Bomp, thanks for the info.

The emulator only has 4.4.2 available and the screen rotation emulation is buggy in that version. The emulator shows the emulated phone screen sideways in Portrait mode and normally in landscape mode, so the rotation event never happens even though the window "rotates". I haven't seen your problem in the other emulator versions where rotation does work or my own real Android devices. Which unfortunately makes fixing it very difficult since I have to guess as to what might be causing the problem.

The rotation itself simply redraws the webcam page, nothing special happens underneath. If the image load works quickly the first time, it should be just as fast after the rotation, there is no difference to what is happening in the code underneath. Does the problem occur if you rotate the phone before all the images have finished loading or does this not make a difference? I'm just wondering if an incomplete page load is causing the display redraw to get stuck. If that is the case, then it's probably being caused by a bug in your version of Android. Working around such bugs is possible (I've done it before), but only if I can replicate the problem.

I've have added some code to ensure the right caching behaviour is being used when loading webcam images, it's just possible your phone has a different default. This will be in the next release of the App. I've also marginally improved the sequential webcam loading, although that is unlikely to have an impact on your problem. Both fixes will be in the next release of the App.

kaiserpc


Posts: 28
Joined: Feb 2015
Last Visited: 15:39
31st Mar 2020
Re: Winterhighland Android App Launched
Date Posted: 17.25hrs on Mon 23 Feb 15
okay just bought the app - slightly more expensive than your average app - but still cheaper than a couple of sandwiches :-). Keen to support it as I've been visiting the website every winter All seems fine, layout is minimalistic and clean. No criticisms of the app so far :-).

Only downside comment from me (and it's my fault once I worked out what it was). When you go back to "All Resorts" it was just showing "The Lecht" - I finally realised this was because I must have scolled to the bottom of this page, so it was showing them all, but going back to the page position I was at previously (but I just couldn't see the others). So I would like it always to jump to the top of the "All Resorts" page when you go back to it.

tim1mw


Posts: 700
Joined: Nov 2006
Re: Winterhighland Android App Launched
Date Posted: 18.37hrs on Mon 23 Feb 15
kaiserpc Wrote:
Only downside comment from me (and it's my fault once I worked out what it was). When you go back to "All Resorts" it was just showing "The Lecht" - I finally realised this was because I must have scolled to the bottom of this page, so it was showing them all, but going back to the page position I was at previously (but I just couldn't see the others). So I would like it always to jump to the top of the "All Resorts" page when you go back to it.


Hi Kaiser, this problem is already on my "to fix" list. In some cases, this bug actually causes the "All Resorts" page to show blank when you return to it until you slide the page up a little bit, at which point it suddenly appears. At least that's what happens on my tablet.

tim1mw


Posts: 700
Joined: Nov 2006
Re: Winterhighland Android App Launched
Date Posted: 20.32hrs on Tue 24 Feb 15
I've just put an update onto the server which should add the "A93 Glenshee South" webcam to the Glenshee webcams page the next time you refresh your report.

tim1mw


Posts: 700
Joined: Nov 2006
Re: Winterhighland Android App Launched
Date Posted: 16.19hrs on Fri 27 Feb 15
Hi All. An update to the app (v1.05) is now available on the play store, you should receive it as part of your normal updates from the play store. The headline improvements/fixes are:

- Lift icons.
- Web links can now be opened using your default browser.
- Webcam images can now be zoomed. Just tap on the image and a suitable viewer with pinch to zoom enabled will open. (Note, a large screen showing a low res web cam probably won't allow any zooming.)
- Small improvement to webcam display.
- The data refresh if the cached report has expired when the app starts will now wait 15 seconds if your internet hasn't finished connecting.
- Links to SAIS and MWIS report pages (note, just a link, not compressed data, so you will be using extra bandwidth)
- The back button will now leave the app.
- The report pages now automatically scroll back to the top when you change page.
- The data download process has been improved and made even more robust.
- The report max cache age option now works properly.

(Bomp: Can you let me know if the update has any effect on your webcam view problem, I haven't forgotten about it.)

geeo


Posts: 426
Joined: Sep 2006
Last Visited: 20:04
7th Feb 2019
Re: Winterhighland Android App Launched
Date Posted: 17.59hrs on Sat 28 Feb 15
Hi Tim

Thx very much for adding those links that's great really fast to check the situation now, I have noticed that clicking on the email address or phone number opens another browser? window it's not a normal browser as I cant go to a different url but it says web page not available at tel:01855851226 or the email address and i'm unable to go back or close the app I have to close it from the home button.

Also when I open the webcams I don't get a proper image, I can almost see the winterhighland banner so something is loading, is this my phones issue?

using a s4 mini on 4.4.2
thx again

alan


Posts: 10768
Joined: Nov 1994
Last Visited: 19:43
29th Feb 2024
What's this?What's this?What's this?
Re: Winterhighland Android App Launched
Date Posted: 20.43hrs on Sat 28 Feb 15
Also when I open the webcams I don't get a proper image, I can almost see the winterhighland banner so something is loading, is this my phones issue?


Is this happening regularly or just occasionally - it might be that you've caught a broken or partially uploaded image which might result in a 404 page not found error page being displayed.

tim1mw


Posts: 700
Joined: Nov 2006
Re: Winterhighland Android App Launched
Date Posted: 22.43hrs on Sat 28 Feb 15
geeo Wrote:
Hi Tim

Thx very much for adding those links that's great really fast to check the situation now, I have noticed that clicking on the email address or phone number opens another browser? window it's not a normal browser as I cant go to a different url but it says web page not available at tel:01855851226 or the email address and i'm unable to go back or close the app I have to close it from the home button.

Also when I open the webcams I don't get a proper image, I can almost see the winterhighland banner so something is loading, is this my phones issue?

using a s4 mini on 4.4.2
thx again


Hi Geeo, I just checked all the webcam pages and they seem to be working OK, so if the problem goes away, I concur with Alan. If the problem doesn't go away, then try going into the config and turn off the "sequential webcam download" option.

Regarding the phone number and email address, nothing should be happening when you tap on them, they are only present for reference. There isn't anything in the code which "activates" phone numbers and email addresses in any way, nor have I seen this happening in 4.4.2 on the emulator, or any other android version, so this is really odd! "tel:0123456789" is mentioned in quite a few places as a way in which you can create a tapable link for a phone number. However, there is nothing in my app which could possibly generate such a link!

It is possible that something outside of the Winterhighland app on your phone has spotted the phone numbers and email addresses and tried to turn them into a standard link in order to be helpful and but the link then fails to work because it isn't supported by the phone. Do you have any Apps which interact with your web browser to enhance your browsing experience? The Winterhighland app uses a web based display layer so it could be affected by web browser settings etc.

I have tried creating a tel: style link as a test on my Galaxy S3 Ace and got the same error which you are seeing, so it would seem that Samsung phones don't actually support this link format. So why such a link would get generated on your phone outside of my code is a real mystery.

Goto Page:  Previous123Next
Current Page:2 of 3
Your Name: 
Your Email: 
Subject: